Jump to content
GreaseSpot Cafe

Unable To Install Extension In Chrome

Recommended Posts

Hello friends. I have been using Chrome browser on my computer for a long time; because that's my favorite web browser. I recently encountered a problem, whenever, I try to install an extension in the Chrome browser, the “Chrome extension is blocked by the administrator” showing this error. Guys, I can’t understand why this is happening and how to fix this issue. Can anyone provide any suggestions to solve this issue? Any help will be appreciated.

Link to post
Share on other sites

The most obvious question is if you're the one with Administrative rights on the computer, and if the user account you're using has admin rights on the computer.  If not, someone would have to log into the Admin account (or AN admin account)  and change the permissions for Chrome for the user(s).

Are you running the most recent version of Chrome?  have you restarted the computer since this happened?    Either might be the resolution of some glitch you encounter.

Link to post
Share on other sites

Thanks for replying. Yes, I have a recent version installed on my computer, and I have tried restarting; but the problem was not solved. I finally found this article after doing a lot of searching on Google yesterday. I have solved my problem by applying a process mentioned there. I just delete the Chrome controller from the registry editor and fixed the issue. Now I can install the Chrome extension without any issue.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...